CVE-2024-22371: Apache Camel issue on ExchangeCreatedEvent

CVE-2024-22371: Apache Camel issue on ExchangeCreatedEvent

Open Source Security [[{„value“:“

Posted by Otavio Rodolfo Piske on Feb 23

Affected versions:

– Apache Camel 1.x through 1.6.0 unaffected
– Apache Camel 3.21.x through 3.21.3
– Apache Camel 3.22.x through 3.22.0
– Apache Camel 4.0.x through 4.0.3
– Apache Camel 4.x through 4.3.0

Description:

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that
exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through…
„}]] Read More 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert