CVE-2024-24772: Apache Superset: Improper Neutralisation of custom SQL on embedded context

CVE-2024-24772: Apache Superset: Improper Neutralisation of custom SQL on embedded context

Open Source Security [[{„value“:“

Posted by Daniel Gaspar on Feb 28

Affected versions:

– Apache Superset before 3.0.4
– Apache Superset 3.1.0 before 3.1.1

Description:

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information
from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Credit:

Beto Ferreira De…
„}]] Read More 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert