CVE-2024-24773: Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

CVE-2024-24773: Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

Open Source Security [[{„value“:“

Posted by Daniel Gaspar on Feb 28

Affected versions:

– Apache Superset before 3.0.4
– Apache Superset 3.1.0 before 3.1.1

Description:

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization
scope.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Credit:

Beto Ferreira De Almeida (remediation developer)
Daniel Vaz…
„}]] Read More 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert