CVE-2024-27315: Apache Superset: Improper error handling on alerts

CVE-2024-27315: Apache Superset: Improper error handling on alerts

Open Source Security [[{„value“:“

Posted by Daniel Gaspar on Feb 28

Affected versions:

– Apache Superset before 3.0.4
– Apache Superset 3.1.0 before 3.1.1

Description:

An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially
crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and
may inadvertently surface in the error log of the Alert exposing possibly sensitive data.

This issue…
„}]] Read More 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert